Slowness across platform

Incident Report for Pike13

Resolved

This incident has been resolved. The primary impact was to search (searching for clients, searching for staff member, etc.).
Posted Dec 17, 2025 - 09:56 PST

Monitoring

Performance has returned to normal, but we are continuing to monitor and investigate.
Posted Dec 17, 2025 - 09:20 PST

Investigating

Our engineers are investigating slow performance and page load times across the platform.
Posted Dec 17, 2025 - 09:06 PST
This incident affected: Your Pike13 Website and API.